Kenevo Gen1 Official 2018/2019 Kenevo thread

Zimmerframe

MUPPET
Subscriber
Jun 12, 2019
13,748
20,422
Brittany, France
Hi, I have 2018 Kenevo Expert with 5.0.0 firmware. I'm using Egenesis and my bike is "unlocked" to 50km/h , but due to the old firmware (i think so?) the peak power is just 15 amps. If I upgrade to newest firmware witch allows me to reach 20amps , can i still use eGenesis and the speed unlock function ? Thanks !
It will all work on 5.0.4 (motor) and A.17.1 (battery).

There is a newer motor firmware than that which as far as I know, it still all works with. Though you could just ask them to upgrade to those ones which will give you the 20a
 

Zimmerframe

MUPPET
Subscriber
Jun 12, 2019
13,748
20,422
Brittany, France
I also have a brose 1.3 with 7.1.1 and it’s so underpowered..what’s the advice here gents? LBS for firmware update?
That's one option, but with 7.1.1 you should have full power.

Can you check how many amps your motor's pulling (Run mission control, select battery, pedal hard in Turbo).

Also check all your assistance settings in Mission Control. At the top of that page there is also an option "presets". You could try that and then re-start the bike to set everything back to standard settings.

Could even be something like some cells down in the battery so it's not giving full voltage. Do you know the battery health ?
 

2wheelsahead

Member
Feb 22, 2023
31
9
Wrexham
Cheers for the response zimmerframe. Battery health is 100, it’s been low on power since I got it but I thought it was just me. Having compared it with my partners it’s night and day different. All parameters are set the same.
 

Zimmerframe

MUPPET
Subscriber
Jun 12, 2019
13,748
20,422
Brittany, France
Cheers for the response zimmerframe. Battery health is 100, it’s been low on power since I got it but I thought it was just me. Having compared it with my partners it’s night and day different. All parameters are set the same.
Can you swap the batteries and see if that makes a difference. It then rules that out as the issue.

Maybe worth also disconnecting and checking the power cable from the motor.
 

2wheelsahead

Member
Feb 22, 2023
31
9
Wrexham
Just at the bike shop, battery needs an update. Will that increase the power? Also the battery has a recall but they are saying it needs to be the original owner to qualify for it.
Not happy about that really
 

cozzy

Well-known member
Aug 11, 2019
748
786
Basingstoke UK
Just at the bike shop, battery needs an update. Will that increase the power? Also the battery has a recall but they are saying it needs to be the original owner to qualify for it.
Not happy about that really
If you have the original receipt, that should be all you need I believe.
 

Zimmerframe

MUPPET
Subscriber
Jun 12, 2019
13,748
20,422
Brittany, France
Just at the bike shop, battery needs an update. Will that increase the power? Also the battery has a recall but they are saying it needs to be the original owner to qualify for it.
Not happy about that really
If you have the original receipt, that should be all you need I believe.
Yup .. here's the recall notice :


There should be no question about being original owner or not.

The thread from here with more info :

 

2wheelsahead

Member
Feb 22, 2023
31
9
Wrexham
Yup .. here's the recall notice :


There should be no question about being original owner or not.

The thread from here with more info :

Cheers..reluctantly they are sorting it..
Bit of a joke really.
Cheers gents
 

vladko33

New Member
Nov 8, 2022
9
0
Europe
Hi all, just updated to 7.1.1 on my Kenevo (thеy told me that just lates firmware is available) and Egenesis stoped working. Any other suggestions for prooved software that can remove 25km/h speed limit on 7.1.1 ?
 

vladko33

New Member
Nov 8, 2022
9
0
Europe
If egenesis has stopped working then they're probably locked out bluetooth adjustments. Shame as it just gives ammunition to the don't ever upgrade your firmware crowd if they use updates to lockout existing access rather than to fix faults.

You could try Blevo, but it works the same way.
Sorry ,maybe my fault. It works , but only reading the bike data with message "this firmware version is not supported" or something like this
 

2wheelsahead

Member
Feb 22, 2023
31
9
Wrexham
If egenesis has stopped working then they're probably locked out bluetooth adjustments. Shame as it just gives ammunition to the don't ever upgrade your firmware crowd if they use updates to lockout existing access rather than to fix faults.

You could try Blevo, but it works the same way.
BLEvo doesn’t work :(
 

2wheelsahead

Member
Feb 22, 2023
31
9
Wrexham
If egenesis has stopped working then they're probably locked out bluetooth adjustments. Shame as it just gives ammunition to the don't ever upgrade your firmware crowd if they use updates to lockout existing access rather than to fix faults.

You could try Blevo, but it works the same way.
Morning Zimmer..my bikes still
Can you swap the batteries and see if that makes a difference. It then rules that out as the issue.

Maybe worth also disconnecting and checking the power cable from the motor.
how do mate..just in wales and my bike is still night and day slower than my partners. I’m so frustrated with this bike now.
 

Zimmerframe

MUPPET
Subscriber
Jun 12, 2019
13,748
20,422
Brittany, France
just in wales and my bike is still night and day slower than my partners
Hey Rob,

If you swap the batteries and your bike is still slower then it suggests there's something wrong with your motor. (And you've already swapped the batteries and I think the power cable)

The "TCU" on the older bikes was contained in the battery rather than being a separate unit on the top tube as it is with the newer bikes. So all the settings should transfer with the battery.

The only other thing could be that it's been swapped for a 1.2e instead of a 1.3.

Have you checked the serial number in Mission Control ?

1681377214225.png


Should start C972, 1.2's will be C911.

Your next option is probably having it looked at by the eBike Motor Centre (@Bearing Man)
 
Last edited:

2wheelsahead

Member
Feb 22, 2023
31
9
Wrexham
Cheers for the response.
I jumped on both mine and my partners and mine kicks out about 10a max compared to 20a with my partners.

I will check the motor firmware also.
31D2E0FA-8C9F-485B-8C8E-C71040BA0478.png
2FF894A5-4D48-4E8A-B3B4-0D6923A9A6EE.png
 

Zimmerframe

MUPPET
Subscriber
Jun 12, 2019
13,748
20,422
Brittany, France
Yeah I just called Berkshire cycles…they will take a look sadly it’s 4hrs from me. Any other ideas gents?
Race Co are probably nearer to you, not sure if they have 1.3's in stock though, but they might be able to confirm and make the trip worth while to Berkshire ?

Ebike Motor Centre as mentioned above is probably nearer to you than Berkshire and might be worth talking too .

+44 1425 656656 - Peter .

It's still possible it's the cable if you've not changed that. Certainly make sure the connection is cleaned with contact cleaner and free of any debris.
 

2wheelsahead

Member
Feb 22, 2023
31
9
Wrexham
Race Co are probably nearer to you, not sure if they have 1.3's in stock though, but they might be able to confirm and make the trip worth while to Berkshire ?

Ebike Motor Centre as mentioned above is probably nearer to you than Berkshire and might be worth talking too .

+44 1425 656656 - Peter .

It's still possible it's the cable if you've not changed that. Certainly make sure the connection is cleaned with contact cleaner and free of any debris.
Cheers for that..

Is that the cable connecting the battery to the motor?
 

2wheelsahead

Member
Feb 22, 2023
31
9
Wrexham
Race Co are probably nearer to you, not sure if they have 1.3's in stock though, but they might be able to confirm and make the trip worth while to Berkshire ?

Ebike Motor Centre as mentioned above is probably nearer to you than Berkshire and might be worth talking too .

+44 1425 656656 - Peter .

It's still possible it's the cable if you've not changed that. Certainly make sure the connection is cleaned with contact cleaner and free of any debris.
Assuming it’s the motor end of the plug that can get oxidation on it? The magnetic battery side seems clean as a whistle
 

Zimmerframe

MUPPET
Subscriber
Jun 12, 2019
13,748
20,422
Brittany, France
Assuming it’s the motor end of the plug that can get oxidation on it? The magnetic battery side seems clean as a whistle
Normally, it's crap in the Rosenberg plug, but if that's clean then you should be ok. The cable could be damaged, but normally that results in different behaviour, not low current readings.

Be prepared that most likely is that your motor is FUBAR ... (or it could just be a single component fault in the motor, but someone finding that .......)
 

2wheelsahead

Member
Feb 22, 2023
31
9
Wrexham
Normally, it's crap in the Rosenberg plug, but if that's clean then you should be ok. The cable could be damaged, but normally that results in different behaviour, not low current readings.

Be prepared that most likely is that your motor is FUBAR ... (or it could just be a single component fault in the motor, but someone finding that .......)
Cheers Zimmer..
I’m normally pretty savvy buying stuff but I recon I was seen a country mile buying this lol.
Ah well…off to the motor place it goes.

What would anyone recommend as a replacement for this bike..I have been a kenevo owner since 2018 and I would like a change.

Cheers

Rob
 

Zimmerframe

MUPPET
Subscriber
Jun 12, 2019
13,748
20,422
Brittany, France
What would anyone recommend as a replacement for this bike
Maybe a Voima .. If you scroll down to the LED ones, they're smart system ones but without the top tube display and a couple of other updates, but are amazingly priced.

 

2wheelsahead

Member
Feb 22, 2023
31
9
Wrexham
Update: my TCU was acting erratically so that’s going to Berkshire for a potential good will exchange and I also bought a motor from
Peter…I’m looking forward to getting the motor in and riding off into the sunset ha.
I’ll let you know how I get on.
Cheers
Rob
 

EMTB Forums

Since 2018

The World's largest electric mountain bike community.

513K
Messages
25,120
Members
Join Our Community

Latest articles


Top