Kenevo SL Motor clunk when stopping pedalling?

Jase

Active member
Subscriber
Apr 22, 2022
99
140
UK
Hello,

My SL has started making a click/clunk noise that can be heard and felt when I stop pedalling. It happens motor on and motor off. Not all the time, but a lot of occurrences. Seems to be getting worse, riding in a group last night and they heard it. Swapped onto my mates Levo SL and nothing from his.
Anyone had the same? Done about 1700 miles so far.

Thanks
 

Jase

Active member
Subscriber
Apr 22, 2022
99
140
UK
my SL do this not. Some other here found such a noise on their SL. My gen3 Levo started to do the same

currently by LSD for checking. The dealer said "it is not normal" Lets see in a week the result.
Thanks, I assume it is not normal as it hasn’t been there for the last 1500 miles and not happening on a friends Levo SL. I have sent a message via Mission Control and will take into the dealer. Still under warranty 🤞
 

Jase

Active member
Subscriber
Apr 22, 2022
99
140
UK
Is the cassette tight?
Yes, it is with the bike shop now so hopefully it will get sorted. Would love the motor replaced with a 1.2, but no chance of that. Will keep this updated in case anyone gets a similar problem.
 

Jase

Active member
Subscriber
Apr 22, 2022
99
140
UK
Just an update, the LBS are putting in a new motor. So how many miles does an SL 1.1 motor last on a uk Mountain Bike? 1700 miles on this one. Thank goodness for warranty and a local Specialized dealer.
 

oceanskipper

Member
Feb 17, 2021
42
6
North East
My Creo with the SL motor has just started doing this also - 1900 miles on the clock and I've owned it from new, bought end Apr 23. Specialized dealer opening a warranty case so I'm hoping it will get a new motor....
 

EMTB Forums

Since 2018

The World's largest electric mountain bike community.

528K
Messages
26,171
Members
Join Our Community

Latest articles


Top