Bosch Flow App

Status
Not open for further replies.

Philodge

New Member
Nov 14, 2023
16
2
Stockport.
A newbie to Bosch motors and one thats confused with the Flow App.

How do I record rides, I did a 20 mile ride on Saturday and nothing recorded in the statistics bit, ie the icon at the bottom of the app.
I use an Iphone and have enabled location to allow access - always.

I click on the Statistics icon and nothing is showing other than an an animated moving bike.

Information on Google doesnt seem to help and some info directs me to the Bosch ebike connect app, which adds more to my confusion.

I do have a Garmin, but would rather stick to one device on the bars if I can get the Kiox 300 to record whats its supposed to record.

Any help would be welcome .. I have no doubt its user error.

Thanks
 

Hattori-Hanzo

Member
Apr 10, 2023
220
209
UK
This could be caused by the phone permissions, Bluetooth settings and power saving settings.

I had issues with my android phone turning off Bluetooth to the kiox after a few minute.

Have a Google for kiox300 phone permissions and you should find something.
 

Philodge

New Member
Nov 14, 2023
16
2
Stockport.
This could be caused by the phone permissions, Bluetooth settings and power saving settings.

I had issues with my android phone turning off Bluetooth to the kiox after a few minute.

Have a Google for kiox300 phone permissions and you should find something.
The Kiox is connected to the phone, no issues there. I can change the mode settings fine
Location settings are all set up correctly
Just can’t see anything else that I need to do that I haven’t done already.
I will see if Bosch can help.
Thanks
 

mcboab

Member
Aug 2, 2022
76
99
NE UK
I have to make sure the flow app is open on the ride tab to record a ride. The app can in theory track the ride always if location settings are set to always which I dont have enabled. i also need to stop the ride in flow app afterwards to save. It takes a few moments to appear in statistics but I have had rides recorded without any tracks occasionally & the stats it sends to Strava are a bit limited.
 

Philodge

New Member
Nov 14, 2023
16
2
Stockport.
It’s officially doing my head in, still nothing showing on statistics .. totally blank
I have got everything ticked that needs to be such as location etc. and still nowt
Contacted Bosch, they sent me an email that just stated the obvious and I had done already
Tempted to delete everything and start again with a reinstall of the Flow App.
 

mcboab

Member
Aug 2, 2022
76
99
NE UK
Before you delete the flow app make sure you haven’t enabled the lock bike function. Or if you have disable the bike lock setting before you do and check it isnt locked without the app running or you may be cursing a bit more.
 

RustyIron

E*POWAH Elite World Champion
Jun 5, 2021
1,434
2,268
La Habra, California
I click on the Statistics icon and nothing is showing other than an an animated moving bike.

I've had my Bosch-powered ride for less than a week, but perhaps my observations can help.

When I first set up the app, I gave it full permissions at every prompt. Like you, I set it up to always allow access. Under "settings," I set up "connected services" for Apple Watch, Apple Health, and Strava.

Tuesday was spent doing the initial tune-up, settings, and blinging out. That involved taking the bike on multiple runs up and down the street. Tuesday night I noticed that the Flow App had uploaded my test runs to Strava. I had a Strava ride of two miles zig-zagging in front of my house. Obviously this wasn't a Strava ride, and it pissed me off. I opened the Flow App and removed all permissions and connected services.

Wednesday and Friday I did some big rides, but used my regular Strava App to record them. All was good and things were operating the way I like.

Just now I opened the Flow App to look at the Statistics that are giving you problems. The only ride shown under Statistics is Tuesdays runs up and down the street. The other two REAL rides are not shown. This seems logical, and it provides two sets of conditions where we can see when the Statistics are logged and when they are not logged.

So the question should be whether you have any "connected devices." Perhaps you could try connected all your devices as I did, and then see if Flow starts logging your rides.
 

Philodge

New Member
Nov 14, 2023
16
2
Stockport.
I've had my Bosch-powered ride for less than a week, but perhaps my observations can help.

When I first set up the app, I gave it full permissions at every prompt. Like you, I set it up to always allow access. Under "settings," I set up "connected services" for Apple Watch, Apple Health, and Strava.

Tuesday was spent doing the initial tune-up, settings, and blinging out. That involved taking the bike on multiple runs up and down the street. Tuesday night I noticed that the Flow App had uploaded my test runs to Strava. I had a Strava ride of two miles zig-zagging in front of my house. Obviously this wasn't a Strava ride, and it pissed me off. I opened the Flow App and removed all permissions and connected services.

Wednesday and Friday I did some big rides, but used my regular Strava App to record them. All was good and things were operating the way I like.

Just now I opened the Flow App to look at the Statistics that are giving you problems. The only ride shown under Statistics is Tuesdays runs up and down the street. The other two REAL rides are not shown. This seems logical, and it provides two sets of conditions where we can see when the Statistics are logged and when they are not logged.

So the question should be whether you have any "connected devices." Perhaps you could try connected all your devices as I did, and then see if Flow starts logging your rides.
Hi I am connected to Strava and Saturdays ride was not uploaded to Strava despite it saying its connected to my account. The statistics tab on the flow app remains empty. I think my only option is to start again with the app.
 

N.R.G.

Member
Nov 17, 2022
29
22
Hampshire
I am probably stating the obvious but have you gone in to the ride screen at the end of your ride and pressed the record (red) button in the top right hand corner of the screen, this usually then finishes your ride and you should then be able to see it in statistics
I also sometimes lose the smartphone connection whilst riding and it tells you this on you Kiox screen and I then have to stop and re-connect to my phone to continue the recording
 

Philodge

New Member
Nov 14, 2023
16
2
Stockport.
I am probably stating the obvious but have you gone in to the ride screen at the end of your ride and pressed the record (red) button in the top right hand corner of the screen, this usually then finishes your ride and you should then be able to see it in statistics
I also sometimes lose the smartphone connection whilst riding and it tells you this on you Kiox screen and I then have to stop and re-connect to my phone to continue the recording
Hi Yes I have pressed the red button to stop the ride, at first I didnt due to not knowing it existed which was down to not reading the manual.
Press the red button .. says that rides will be visible shortly and it never happens.
 

RustyIron

E*POWAH Elite World Champion
Jun 5, 2021
1,434
2,268
La Habra, California
I am probably stating the obvious
Thanks for the tip. I'm going to try it out this morning. I'll be running Strava on my watch, just in case. Since you seem to know what to do, can we walk though it again?

1. Start Flow App.
2. Ride.
3. At end of ride, it the big red button.

Questions:

1. Since I've allowed Flow to always access my location, do I have to start the App?
2. Is there a Start Button that I need to press?

Thanks.
 

Philodge

New Member
Nov 14, 2023
16
2
Stockport.
Thanks for the tip. I'm going to try it out this morning. I'll be running Strava on my watch, just in case. Since you seem to know what to do, can we walk though it again?

1. Start Flow App.
2. Ride.
3. At end of ride, it the big red button.

Questions:

1. Since I've allowed Flow to always access my location, do I have to start the App?
2. Is there a Start Button that I need to press?

Thanks.
I think its supposed to start automatically once you start moving, I have no way of knowing if that actualkly happens as I cant see any of the rides I have done. I dare say when it works its great :):)
 

N.R.G.

Member
Nov 17, 2022
29
22
Hampshire
I think its supposed to start automatically once you start moving, I have no way of knowing if that actualkly happens as I cant see any of the rides I have done. I dare say when it works its great :):)
Have you tried restarting your phone ? if you are like me I just plug it in and recharge before it runs out of battery but sometimes it needs a restart for changes to take effect
 

Philodge

New Member
Nov 14, 2023
16
2
Stockport.
Have you tried restarting your phone ? if you are like me I just plug it in and recharge before it runs out of battery but sometimes it needs a restart for changes to take effect
Yep, done all that and while I was on the phone to Bosch Flow App support.
They advised me to delete the bike from the app and then delete the app and in effect start again.
Problems is .. the bike wont delete from the App
So now it's been raised as a tech query and they are looking into it.
No further on with finding a solution but hopefully if they get back to me they will have an answer.
 

Ark

Member
Mar 8, 2023
350
297
Newcastle Upon Tyne
Works perfect for me.

No power saving restrictions on the app.
can run in background forever.
Can autostart

The apps kinda meh though I don't like how the only way to have saved routes is via komoot
then the app needs an internet connection to download the route, it doesn't get stored anywhere..
Ridiculous that the app doesn't have the ability to save/load routes directly from your phones storage..

I bet almost any coder could add that feature in 5 minutes.
I've got yhr Bosch smart phone mount so use the flow app as a display and sometimes it's completely froze up. restarting it always recovered the stats for the current ride I'm on though.

on the google play store nearly all the reviews of the app when I last checked were complaints lol
 
Last edited:

Philodge

New Member
Nov 14, 2023
16
2
Stockport.
All sorted (I think) Bosch told me to delete everything and reload the app, login again and its now showing some previous rides. Looks like the one's missing are from post app update, possibly a bug in the app. Time and sh1t weather have stopped me going out for a full test .. fingers crossed for this weekend.
Thanks for the suggestions and help with this matter.
 

scrufy

New Member
Jan 29, 2024
17
7
So Cal
Good to know I don't have to start the flow app first.
I always started the bike, started flow, then forgot and an hour after the ride went in and pressed the little red square button. Always saved to flow, strava, and fit np but if I don't even have to open flow, all the better.
 

RustyIron

E*POWAH Elite World Champion
Jun 5, 2021
1,434
2,268
La Habra, California
One more data point:
Yesterday I decided to give the Flow App one more shot. It "disconnected" half way through the ride. Maybe I'll try it again when they come out with a new version of the app or firmware, but for now I'm done wasting my time.
 

Rob Rides EMTB

Administrator
Staff member
Subscriber
Jan 14, 2018
6,139
13,184
Surrey, UK
Thread continued here:

 
Status
Not open for further replies.

EMTB Forums

Since 2018

The World's largest electric mountain bike community.

513K
Messages
25,121
Members
Join Our Community

Latest articles


Top