Bosch Kiox 300 vs Flow app: not pairing

tommygun

New Member
Apr 3, 2022
12
8
Rome
Hello there,

I'm really struggling with the Bosch Flow app on Android, and I'd like to understand if I'm the only one here with this issue.

I have a 2022 Cube Stereo Hybrid 140 TM (great bike) with the latest Bosch smart system.

The first time I've set up the app on my smartphone and paired it with the Kiox all went super smoothly. The app retrieved all the info from the bike and logged my first test drive on the map, all cool.

Then after a few days I went for another trip and noticed that the app didn't automatically connect back to the bike, despite having the process running in the phone (you can see the notification in the task bar below) and having the BT turned on, etc.

Screenshot_20220516-110327_One UI Home.jpg


Even if I open the Flow App it keeps telling me that I'm not connected, despite having the bike turned on in front of me.

The only way I've fount to make it connect again is to turn the pairing mode on on the bike, by long pressing the power button, AND killing the flow process in the smartphone and launching it again. By using this procedure they pair again and work as intended, BUT the app loses connection again after a few minutes/hours, so I'm back to square one.

I've also tried to delete and reinstall the Flow app, to no avail.

Any Idea?

Thanks a lot!
 

BikeawaySpain

New Member
Oct 14, 2022
18
11
Spain
After the latest update, it has become even worse. Flow does not want to connect anymore with the bike. It does find the bike via Bluetooth but then connection fails. Called Bosch, seems I am not the only one.... waiting now for update.
 

BikeawaySpain

New Member
Oct 14, 2022
18
11
Spain
After the latest update, it has become even worse. Flow does not want to connect anymore with the bike. It does find the bike via Bluetooth but then connection fails. Called Bosch, seems I am not the only one.... waiting now for update.
Update, after finding this on German bike channels on Youtube. If you delete Flow and the related Bluetooth link to Smart system, and then re-install Flow and reconnect with Bluetooth, I was able to connect again. I had to install Flow twice to reach this result. Not very user-friendly, but at least we now have Navigation support on Kiox 300 and better mileage indication.
 

Paul Mac

E*POWAH Elite World Champion
Patreon
Subscriber
Jul 9, 2018
990
1,043
Uk
Update, after finding this on German bike channels on Youtube. If you delete Flow and the related Bluetooth link to Smart system, and then re-install Flow and reconnect with Bluetooth, I was able to connect again. I had to install Flow twice to reach this result. Not very user-friendly, but at least we now have Navigation support on Kiox 300 and better mileage indication.
I had exactly the same issue with the flow app not connecting after the update.
Unistalled, reinstalled all works now, but keeps saying my phone app needs updating to latest version, but it already is the latest version?
 

Pazman

Member
Dec 8, 2022
87
97
Uk
I'm having this issue now on 2 ebikes I own .
Only started after the last firmware update , its been to Bosch dealer for firmware forced update but still no fix.
Bosch have been terrible and next to no use at all . Taking 7 days to reply to emails and offering no help at all .
£18000 on 2 Bosch bikes a cannot use ha
 

EMTB Forums

Since 2018

The World's largest electric mountain bike community.

521K
Messages
25,694
Members
Join Our Community

Latest articles


Top