Kiox Controller Communication with Kiox Display Issues

Jun 23, 2022
9
3
USA
Hi, all.
Back story. Ran my Bosch CX Gen 4 on my 21 Trek Rail 9.8 for over 3800 miles problem free.
Then an issue developed with the Kiox controller seemingly not communicating with the Kiox display.
I.e., Kiox display turns on as normal in the off position but the controller buttons don't change anything on the display when toggled.
At times, the system would work just fine but then the motor would turn off during the ride.
So I changed the remote with a brand new one. All worked instantly as normal.
Then around Christmas time last year, same symptoms came up.
This time, controller would not engage with the Kiox display at all and system turns off in 2 mins.
The system normally turns off when not in use after 10 mins.
Took it to the shop - long story short - the shop and bosch warrantied the old motor with a brand new one.
New Kiox remote was installed as well.

Fast forward to my last two rides:
After 580 miles on the motor, the motor turned off during my ride up in the high elevation in near freezing temp. It was very cold.
Turned the Kiox display on as normal, the controller did not communicate with display. Ugh!!!!
Cycled the display and attempted communication a few times and the two finally communicated.
The motor stays running as long as I'm pedaling.
Kiox would turn off in two minutes or less when stopped.
Then I had to cycle through again to have the two communicating again.

It did this again today on a cold morning ride (40degF).
One time, a green check box appeared on my Kioxx display saying "Sychronizing" before it shut off.
My Bosch app is not turn on or running. Suffice to say, I was forced to ride an acoustic bike for a couple of miles.
I cycled the Kiox unit again a few times and finally, the controller worked with the Kiox but this time, there's a lag in switching modes.
Called my buddy at Bosch USA and other than going to the shop to plug the system on dealer diagnostic to perform a button test, I'm stuck.

Sorry for the long winded post but has anyone experienced something similar to what's been going on with my CX Gen 4 with Kiox system?
 
Jun 23, 2022
9
3
USA
Ps:
These symptoms and erratic nature of the Kiox units I've been experiencing also occurs when the bike is just clamped on the stand (not in motion). Any help or just insight would be helpful.
 

Stihldog

Handheld Power Tool
Subscriber
Jun 10, 2020
3,006
4,219
Coquitlam, BC
2020 Rail 9.7 with 10K+ kms. The only physical problem I had with the Kiox controller was when I crashed and broke the clamp. I taped it in place until a new controller arrived later that week.

The kiox display is held in the holder with a magnet. Between the Kiox and holder there are 7 contacts (3 on one side, 4 on the other). These are easy to clean if dirt or water finds a way in there. I ride in wet/rainy conditions all the time and only occasionally wipe the contacts with my glove.

The Kiox wiring harness to the motor must not be pinched or compromised. It runs nicely through the head tube, battery compartment, lower battery bulkhead, motor compartment and finally plugs into the motor at a specific port. The female port must be clean.

My issue sounded somewhat similar to yours. Vibrations would cause intermittent power to the motor and strange behaviour to the Kiox electrical system. A poor connection at rest can also cause these problems. With all the possibilities, including faulty electronics, I finally found the problem. A poor connection between the battery and wiring harness at the lower battery bulkhead. There is a procedure for this. I tightened up and slightly moved the bulkhead. I haven’t had an issue or power failure since (almost two years).

It’s a process of elimination, which your LBS is trying to do. This mystery was driving me crazy. My solution came as a suggestion from a member on this forum. 🙏
 
Jun 23, 2022
9
3
USA
This is driving me mad. It's been so inconsistent.
Wiring looks good. I have triple checked everything.
Battery in the Kiox has been charged (via USB).

Today has definitely been the weirdest and frustrating experience.
So livid with how helpless it renders me to not know WTH is going on.

So to recap today's frustrating Kiox event:
The Kiox would turn on but stuck in OFF mode.
Kiox shows wheel speed when the motor is pedalled engaging the speed sensor.
So there is good communication between the motor and the Kiox.
At times, it would take 1 whole minute for the controller to finally talk with the Kiox.
When this happened, the system works as normal.
I was able to ride for 20 miles today.
During this whole ride, when we stopped, the Kiox would turn off.
At times, it would take a minute for the controller to toggle assist with the Kiox.
A few times, it took more than 2 minutes and a few times the Kiox will turn off.
NO issues occurred while riding when it was engaged. No power interruption,
When I got home, the Kiox and controller communicated on demand.
An hour later, Kiox would just turn on and controller wouldn't communicate any longer.
Did hard reset and all but nothing worked.
Will head to the dealer tomorrow to plug it in and diagnose.
Just pissed off right now. I can't wait to sell this bike once fixed (for the second time).
Ugh... If you've read this far thanks for letting my vent lol.
 

EMTB Forums

Since 2018

The World's largest electric mountain bike community.

528K
Messages
26,173
Members
Join Our Community

Latest articles


Top