Internal Power Cable Failure, Levo 2019

Zimmerframe

MUPPET
Subscriber
Jun 12, 2019
13,736
20,395
Brittany, France
How many versions of cable is there. I got new one January 20 for my 19 expert the old one had crack in it. New one i got was flat instead of round. Now im told i need a new cable as its the old version which lets in water.
Was it supposed to be flat or had it been crushed ? :)

I thought there was the old one (which was prone failure) and the new one S206800004. Then there's the new new one for 2022 bikes, but that's completely different.

There's also the S176800002 for 1.2 and 1.3 motored bikes, but you're a 2.1 guy so not applicable.
 

neils

Well-known member
Aug 28, 2018
201
114
Wokingham UK
How many versions of cable is there. I got new one January 20 for my 19 expert the old one had crack in it. New one i got was flat instead of round. Now im told i need a new cable as its the old version which lets in water.

I'd speak to Chris at Berkshire Cycles for an honest and up to date answer.
 

Binhill1

🍊 Tango Man 🍊
Mar 7, 2019
2,430
3,508
Scotland
Was it supposed to be flat or had it been crushed ? :)

I thought there was the old one (which was prone failure) and the new one S206800004. Then there's the new new one for 2022 bikes, but that's completely different.

There's also the S176800002 for 1.2 and 1.3 motored bikes, but you're a 2.1 guy so not applicable.
It was flat when it came been ok actually. Washed last week and having to unplug and plug in to get it to start then away it goes. Leave it an hour same again.Its back with dealer for frame issue and he said its old style cable i need a new one. Just wondering . Still miles too long the cable or am i missing something
 

Mikerb

E*POWAH Elite World Champion
May 16, 2019
6,058
4,579
Weymouth
regardless of your fix, for the benefit of others wondering a bout their battery to motor cable...............the V2 as fitted to 2019 and some 2020 bikes had a continuous fairly stiff black outer casing and there was one zip tie near the battery end whose purpose was only to prevent the cable being pulled out of the exit gap of the motor cover.
The replacement V3 cable has a significant portion of that stiff outer casing removed along its length, replaced with a flexible casing. In addition the outer casing is secured to the terminals at each end with small white zip ties. The problem with the V2 was that the outer casing was so stiff, the necessary bend in the cable to fit it into the space under the motor cover placed too much strain on the "D" shaped motor end terminal and tended to either break the connection between the casing and the terminal or crack open the terminal itself..........or both. Either way it could then allow water ingress to the cables inside the casing and/or short out the cables. The removal of part of the outer casing on the V3 coupled with far better sealing at both terminal end plugs eliminated those problems.
 

RebornRider

Well-known member
May 31, 2019
551
516
NorCal USA
FWIW, my V2 cable split as Mikerb states, which led to the dead bike syndrome. I cleaned the cable thoroughly, then wrapped it with electrician's tape (not sure about the UK term) wound as tightly as I could make it. No more dead bike after a wash or a stream crossing.
 

Mikerb

E*POWAH Elite World Champion
May 16, 2019
6,058
4,579
Weymouth
FWIW, my V2 cable split as Mikerb states, which led to the dead bike syndrome. I cleaned the cable thoroughly, then wrapped it with electrician's tape (not sure about the UK term) wound as tightly as I could make it. No more dead bike after a wash or a stream crossing.
I replaced mine before it had a chance to cause problems. I kept my original cable and stripped off a section of the outer casing to create a more flexible cable. I cover the exposed wires with amalgamating tape plus a protective layer of insulating tape. I then used Aquasure to create good seals between the cable casing and the terminals at each end.

20211123_184000.jpg
 

Binhill1

🍊 Tango Man 🍊
Mar 7, 2019
2,430
3,508
Scotland
I replaced mine before it had a chance to cause problems. I kept my original cable and stripped off a section of the outer casing to create a more flexible cable. I cover the exposed wires with amalgamating tape plus a protective layer of insulating tape. I then used Aquasure to create good seals between the cable casing and the terminals at each end.

View attachment 76618
So V3 still not the best . Aquasure you plug in the cable and smear outside. Cheers
 

Mikerb

E*POWAH Elite World Champion
May 16, 2019
6,058
4,579
Weymouth
So V3 still not the best . Aquasure you plug in the cable and smear outside. Cheers
to avoid any confusion the a bove is what I did to repair/improve the V2 cable which I keep as a spare. I have had the V3 cable installed without any additional mods to it for over 18 months and no issues.
 

salko

E*POWAH Elite World Champion
Aug 29, 2019
1,235
834
SLO
I came across a new version of the motor-to-battery cable (is this v4 or v5 already?) for Gen2 Levos and Kenevos MY20-22, anyone already tried it? Latest now comes with a flat cable (just like on Gen3) and better cable-to-connector inlets, looks like issues with falling apart cable might be finally over, but as most of Gen2 Levos are now out or near the end of the warranty period, quite expensive replacement ... Did anyone get it as warranty replacement maybe?

 

Binhill1

🍊 Tango Man 🍊
Mar 7, 2019
2,430
3,508
Scotland
I came across a new version of the motor-to-battery cable (is this v4 or v5 already?) for Gen2 Levos and Kenevos MY20-22, anyone already tried it? Latest now comes with a flat cable (just like on Gen3) and better cable-to-connector inlets, looks like issues with falling apart cable might be finally over, but as most of Gen2 Levos are now out or near the end of the warranty period, quite expensive replacement ... Did anyone get it as warranty replacement maybe?

My cable is flat I got it December 21 on warranty. Nothing wrong with it but bike was in for other stuff and they replaced it. Not sure which version it is but I have had no issues with it since fitted. It's the 2nd one replaced On warranty first one had a crack on the motor connection side .
 

EMTB Forums

Since 2018

The World's largest electric mountain bike community.

512K
Messages
25,073
Members
Join Our Community

Latest articles


Top