Levo SL Gen 1 Turbo Levo SL: squeak on big jumps, not from suspension

Cannikin

Member
Oct 15, 2019
36
49
San Marcos, CA
So in the last month or so I've developed a pretty big squeak when I launch on bigger jumps...just hopping on flat ground doesn't seem to cause it, it's only if I hit something fairly big.

My assumption was the front or rear suspension, but I've since swapped them both out and I've got the exact same sound. I can't really tell where it's coming from when I'm riding. The only other moving parts are the rear linkage and the axles. Is it possible I need to lubricate something in the linkage? I figured those were sealed bearings, but maybe not?
 

apac

E*POWAH Elite World Champion
Aug 14, 2019
1,326
1,171
S.Wales
Lube your axles. That got rid of a squeak for me. It could be something inside the frame. It could be crank or motor too.
 

St4nley

Well-known member
Subscriber
Nov 17, 2020
150
324
Derbyshire
Are you sure it’s not your new knee ?my Sl doesn’t creak but then I do have both my own knees still .
 

gbarfoot

Active member
Sep 1, 2020
184
163
Colorado usa
Have you checked the swingarm chain stay bolt on the drive side behind the sprocket? I read on here that many were loose and eventually caused damage if left in checked....I checked mine and it was loose but not horrible....not sure if it would cause the squeek but worth checking
 

EMTB Forums

Since 2018

The World's largest electric mountain bike community.

499K
Messages
24,234
Members
Join Our Community

Latest articles


Top