GPS application map mismatch

Vindic8

New Member
Jun 2, 2023
9
1
PNW
Hello, new forum member here. I did a search but did not find the answer.

I live in a northern climate where we get a fair amount of snow. That means outdoor riding stops for me in the fall and picks back up in the spring.

I have a Bosch ebike with a Kiox computer. I use the eBike Connect via Bosch and FitBit simultatiously to track rides.

Last fall the mapping matched nearly identically between the two. Since I started again on the Spring the FitBit map is consistently accurate and the eBike Connect map is a mess. Same phone device, same GPS access. It appears that the location polling is far more infrequent now on the eBike Connect. Does anyone know the trick here? Is there a setting for adjusting poll frequency? Examples attached.

eBike 6-23.jpg eBike 9-22.jpg FitBit 6-23.jpg FitBit 9-22.jpg
 

Shark58

Active member
Mar 5, 2023
186
132
Germany
Recently there was an update for the eBike Connect app and the corresponding Bosch portal which included new maps. After updating the app you need to update the offline maps on your device. Open the app and go to more - settings - offline maps. Check that you have all your relevant regions updated. Then try the ride again.

If this doesn’t help, there ist a problem with either the GPS reception, your phone’s network coverage or the Bluetooth connection between phone and Kiox. The dotted lines in your ride normally indicate some sort of signal loss during parts of the ride and Bosch will make those up.
 

casian

Member
Feb 10, 2021
17
15
Bristol
Hi Vindic8. I have exactly the same problem since the last update. It appears to have got worse. If I keep my phone screen on there is no problem it doesn't drop the GPS connection,when it sleeps about 20 seconds later it disconnects and reconnects at random giving me straight lines on the mapping, sometimes for miles. I have updated maps but it's still the same. Did you get to the bottom of it?
 

Vindic8

New Member
Jun 2, 2023
9
1
PNW
No, updating the map did not improve the situation. I have also gone into the android settings item for item, to insure the same GPS rights, access, etc. were mirrored between FitBit and eBike. Im not sure why the GPS polling interval changed between the two applications. I have noticed a correlation with battery saver modes. If I implement battery saver then the apps will go to sleep and both will reflect a truncated ride.
 

casian

Member
Feb 10, 2021
17
15
Bristol
I have had another go tonight. I really thought it was to do with the permissions on my Samsung phone. I have been over them so many times so I tried a couple of new idea's I logged out the app and back in again, that seemed a slight improvement, gps stayed connected for longer, I put the phone in my pocket and it disconnected again!
Then I thought I'll try cleaning the contacts on the Kiox and the base with some isopropyl alcohol. It instantly connected and stayed connected, no gps dropout. This was done in the garage so fingers crossed it will work on tomorrow's ride.
I'll keep you posted!
 

Vindic8

New Member
Jun 2, 2023
9
1
PNW
Wow, I'm going out to the garage to do the same. I'll report back my experience on tomorrow morning's ride.
 

casian

Member
Feb 10, 2021
17
15
Bristol
Set off on my ride this morning, stayed connected for about 100ft, then back to intermittent connection! I also had my Galaxy watch connected and heart rate monitor. Disconnected both and mounted phone to the handle bars, next to the Kiox. It still randomly disconnected. Got home, put bike in garage where the gps signal is not great, I left it while I got showered and changed . I then turned it back on, it connected straight away and I kept the motor awake and it hasn't dropped the connection in the last hour. What is going on?
Galaxy watch recorded the ride perfectly, with accuracy too one meter all the way!
This has happened since the last update so I can only assume it has to do with the Bosch coding.
 

Vindic8

New Member
Jun 2, 2023
9
1
PNW
So today I watched the connection checkmark in the lower left hand corner of the Kiox display very closely. My phone is also mounted to the handlebar about six inches from the Kiox unit. Several minutes into my ride my phone screen went to just the blank screen with the time displayed. Shortly after that the checkmark turned yellow indicating that the connection between the phone/eBike app and the Kiox unit had stopped. I 'woke' the phone up and placed it on the fitbit app screen. Every few minutes for the remainder of the ride I swiped down on the screen to evoke a sync between the fitbit app and my fitbit device. This process kept the phone from going into any measure of sleep mode for the apps.
The result after the ride was such that I could see a short break in the mapping on my ebike result around the time the checkmark was yellow. The remainder of the ride mapped perfectly. I conclude that under the same conditions FitBit can keep its GPS active in the background and eBike seemingly cannot. I am running Android version 13.
 

Vindic8

New Member
Jun 2, 2023
9
1
PNW
I did a deeper dive looking for config/optimization differences between the two apps and found one difference. If one holds down on an app's icon it brings up a dialog. On that dialog is the 'info' icon in the top right corner. In the list of options there is a 'Battery' section. Three options. Unrestricted, Optimized and Restricted. I found that FitBit was set to Unrestricted and eBike was set to Optimized. I am going to set eBike to Unrestricted and see what the results are on tomorrows ride.

Screenshot_20230613_143607_Settings.jpg
 

casian

Member
Feb 10, 2021
17
15
Bristol
Well done! This is the setting I've been trying to find. I didn't think it existed any longer.
I'm sure you have found the reason.
I will try it again tomorrow.
 

Vindic8

New Member
Jun 2, 2023
9
1
PNW
I went for a ride this morning as well. Watched the connection icon and didn't lose connection for the whole ride. The map detail level matched perfectly between The FitBit and the eBike apps. So that portion is now working. Will have to monitor to see if the re is now an adverse tradeoff with the eBike app and battery life.
 

casian

Member
Feb 10, 2021
17
15
Bristol
I've had the Kiox now for about three years and other than a few teething problems when it first came out, it has been really reliable without appreciable drain on the phone battery. I did purchase the cable to charge the phone from the Kiox if I was going on a long ride using the gps.
So I don't think you will have a problem.
Good to know yours is now working as it should.
 

suzie74

New Member
Jun 16, 2023
2
2
Queensland, Australia
Hi guys, I'm so glad i have found your conversation. I have only had the kiox for about a month and have got the same problem (straight lines on my rides). I have adjusted the battery setting as you shown above. I'll be testing it out tomorrow , hopefully issue has been fixed.
 

Vindic8

New Member
Jun 2, 2023
9
1
PNW
Hello Susie, I have had three straight rides now with successful mapping. I sure hope it works for you as well.
 

EMTB Forums

Since 2018

The World's largest electric mountain bike community.

531K
Messages
26,402
Members
Join Our Community

Latest articles


Top