2022+ Turbo Levo Lights wired directly to Levo motor / battery on Gen3

rennis

New Member
Nov 2, 2022
2
2
Seattle
As reported above you can simply disconnect the cable too to disable the light. I might look at printing a couple of rubber plugs to keep on the ends for this purpose.

Hey spicker. If you end up printing some plugs for the light cables I'd be interested in buying some from you, cover S&H, etc. this is a great idea.

Appreciate the info in this thread, I got a 906S wired-up last night on my Levo. works great, glad I learned about enabling the e-bike mode here. I will say getting that wire run through the frame was a chore!
 

ryandoubleu

New Member
Jul 3, 2022
15
8
USA
Hey spicker. If you end up printing some plugs for the light cables I'd be interested in buying some from you, cover S&H, etc. this is a great idea.

Appreciate the info in this thread, I got a 906S wired-up last night on my Levo. works great, glad I learned about enabling the e-bike mode here. I will say getting that wire run through the frame was a chore!
Add me to the list as well
 

spicker

Member
May 2, 2022
136
115
Newfoundland, Canada
Here’s the first go for the male plug end. 5628839E-CE67-4331-B4F3-373D9CC43309.jpeg 218D8F49-9B1C-437F-A174-AA50A1862272.jpeg 42CF5F31-DC9A-49FA-B428-D508FC9A6B28.jpeg
 

The_Badger

Member
Jan 24, 2021
3
3
Bristol
I’ve experienced similar things to you guys. An mj906 light stuck in battery mode needs an alternate power source to the Levo’s hard wire If you’re returning it to e bike mode. Mine was an old magicshine battery.
in e bike mode avoid high power or like me your light will occasionally cut out without warning… lethally dangerous On a descent (Unless you like that sort of thing!)
in low and mid power I’ve had no issues with the light switching off…yet!

the only other thing to note is the automatic switch from daylight to nighttime is super sensitive. It switches the light From full power to daylight saving all the time at dusk or in town lighting which is kind of annoying, and would be a bit dodgy in a dingy forest too.
 

BruceJR

New Member
Jun 16, 2022
54
24
USA West
I have not experienced the MJ906S turning off in mid ride. I have it wired directly and turn it on and off by toggling from ebike mode the standard mode. So far so good. If it EVER randomly turns off unexpectedly it's getting replaced with a Lupine. I hope that never happens.
 

psst!!!...

Member
Mar 2, 2022
20
8
Portugal
Did you try it it the dark ? - I haven't yet, and I just read that "As an e-bike LED light, MJ-906S automatically adjusts its output levels", so maybe it doesn't work at all in daylight.

Yes I covered up the light sensor. It also gave some motor errors in mission control mentioning that it’s trying to draw too much power :-(
[/QUOTE]


Does anybody tried the MJ-906S with Gen3 turbo levo? does it work?
 

ryandoubleu

New Member
Jul 3, 2022
15
8
USA
Yes I covered up the light sensor. It also gave some motor errors in mission control mentioning that it’s trying to draw too much power :-(

Does anybody tried the MJ-906S with Gen3 turbo levo? does it work?


If you read through the thread it does work but you have to put it in ebike mode and there are instructions in the thread for doing that as well.
 
Last edited:

BruceJR

New Member
Jun 16, 2022
54
24
USA West
Yes I covered up the light sensor. It also gave some motor errors in mission control mentioning that it’s trying to draw too much power :-(


Does anybody tried the MJ-906S with Gen3 turbo levo? does it work?
[/QUOTE]

I have the MJ-906S wired directly to my Gen 3 Levo. It works fine. I manually toggle between e-bike mode and standard mode. I leave it turned off 99.99% of the time via standard mode. Then if I need light, I turn it on and switch to e-Bike mode by holding the button for 8 seconds. It's never cut out and seems to work flawlessly. I do not even connect via Mission Control because I'm derestricted so I cannot comment on over voltage errors. I did say most of this in my previous post btw.
 

psst!!!...

Member
Mar 2, 2022
20
8
Portugal
Does anybody tried the MJ-906S with Gen3 turbo levo? does it work?

I have the MJ-906S wired directly to my Gen 3 Levo. It works fine. I manually toggle between e-bike mode and standard mode. I leave it turned off 99.99% of the time via standard mode. Then if I need light, I turn it on and switch to e-Bike mode by holding the button for 8 seconds. It's never cut out and seems to work flawlessly. I do not even connect via Mission Control because I'm derestricted so I cannot comment on over voltage errors. I did say most of this in my previous post btw.
[/QUOTE]

Thanks, sorry i didnt read all posts before.
I will connect it soon.
Just curious: you say you toggle between modes without any problem while other people mention that if switch to high power mode shut off and need an external batt to swicth on and change to ebike mode again before connecting to bike.
It may be an upgrade either on the light or specialized.
 

BruceJR

New Member
Jun 16, 2022
54
24
USA West
I have the MJ-906S wired directly to my Gen 3 Levo. It works fine. I manually toggle between e-bike mode and standard mode. I leave it turned off 99.99% of the time via standard mode. Then if I need light, I turn it on and switch to e-Bike mode by holding the button for 8 seconds. It's never cut out and seems to work flawlessly. I do not even connect via Mission Control because I'm derestricted so I cannot comment on over voltage errors. I did say most of this in my previous post btw.

Thanks, sorry i didnt read all posts before.
I will connect it soon.
Just curious: you say you toggle between modes without any problem while other people mention that if switch to high power mode shut off and need an external batt to swicth on and change to ebike mode again before connecting to bike.
It may be an upgrade either on the light or specialized.
[/QUOTE]
I make sure to switch to e-bike mode immediately after switching it on. If you prefer to have the light always on then you can just leave it on in e-bike mode and it will always be on. I think the faults occur when the e-bike tries to modulate the voltage output when the light is not in e-bike mode. Don’t let that happen by riding around in standard mode and hopefully you will be fine. I’ve used it like 10 times without issue.
 

psst!!!...

Member
Mar 2, 2022
20
8
Portugal
Thanks, sorry i didnt read all posts before.
I will connect it soon.
Just curious: you say you toggle between modes without any problem while other people mention that if switch to high power mode shut off and need an external batt to swicth on and change to ebike mode again before connecting to bike.
It may be an upgrade either on the light or specialized.
I make sure to switch to e-bike mode immediately after switching it on. If you prefer to have the light always on then you can just leave it on in e-bike mode and it will always be on. I think the faults occur when the e-bike tries to modulate the voltage output when the light is not in e-bike mode. Don’t let that happen by riding around in standard mode and hopefully you will be fine. I’ve used it like 10 times without issue.
[/QUOTE]

Will do that! Thank you.
 

psst!!!...

Member
Mar 2, 2022
20
8
Portugal
Light installed. Quick test and seems to work flaulessly.
immediatly setup to ebike mode as recomended.

now busy finding a proper way to use both the garmin and the light in such a way they both get centered and witrh good looking!!
 

BruceJR

New Member
Jun 16, 2022
54
24
USA West
The light has a GoPro type mount so it works perfectly with the Garmin out front mount and GoPro adapter. I use the mount for my Android Blevo phone but it certainly can work with an Edge.
0BBE183B-1015-41E7-A0E5-C400B79ABF65.jpeg
 

psst!!!...

Member
Mar 2, 2022
20
8
Portugal
My first ride with the light, daytime. It turned the bike off after some kms when climbing. Error message on the tcu.
Light also off.
Turn bike on again and made sure the light was on emtb mode (pressing 10sec until button flashed red) and mase 40kms more without a problem.
 

psst!!!...

Member
Mar 2, 2022
20
8
Portugal
Thanks, sorry i didnt read all posts before.
I will connect it soon.
Just curious: you say you toggle between modes without any problem while other people mention that if switch to high power mode shut off and need an external batt to swicth on and change to ebike mode again before connecting to bike.
It may be an upgrade either on the light or specialized.
I make sure to switch to e-bike mode immediately after switching it on. If you prefer to have the light always on then you can just leave it on in e-bike mode and it will always be on. I think the faults occur when the e-bike tries to modulate the voltage output when the light is not in e-bike mode. Don’t let that happen by riding around in standard mode and hopefully you will be fine. I’ve used it like 10 times without issue.
[/QUOTE]


one question: when we put it on ebike mode and then we shut down the bike (and light) and turn the bike on again, does the light starts on ebike mode (latest status before being shut down) or do we need to put it back in ebike mode (everytime we turn it on)?
i previously understood the light keeps in the latest stautus mode but when i tried mine last saturday it died and engine error message appear but i restarted it ebike mode and never failed again. i was sure i left in ebike mode the night before...
 

BruceJR

New Member
Jun 16, 2022
54
24
USA West
I make sure to switch to e-bike mode immediately after switching it on. If you prefer to have the light always on then you can just leave it on in e-bike mode and it will always be on. I think the faults occur when the e-bike tries to modulate the voltage output when the light is not in e-bike mode. Don’t let that happen by riding around in standard mode and hopefully you will be fine. I’ve used it like 10 times without issue.


one question: when we put it on ebike mode and then we shut down the bike (and light) and turn the bike on again, does the light starts on ebike mode (latest status before being shut down) or do we need to put it back in ebike mode (everytime we turn it on)?
i previously understood the light keeps in the latest stautus mode but when i tried mine last saturday it died and engine error message appear but i restarted it ebike mode and never failed again. i was sure i left in ebike mode the night before...
[/QUOTE]

I’m pretty sure it stays in the previous mode when turned off. For example, I turn it on and change to ebike mode. Then after the ride change back to standard mode to power off. When I turn the bike on again the light stays off. If it was somehow changed to ebike mode it would not stay turned off. I have not played around with leaving it in ebike mode as I prefer the light to be off 99% of the time.
 

spicker

Member
May 2, 2022
136
115
Newfoundland, Canada
Yes, once in eBike mode, it ill remain in eBike mode. I have mine wired to the motor, and once switched over to eBike mode, I have not had any issues with the light or the bike. It runs as a day time light during the day, and switches to the two brighter settings as it gets darker.
 

psst!!!...

Member
Mar 2, 2022
20
8
Portugal
Ok, thank you for all inputs.
I share pictures of the setup i got.
Not sure if the mount will be strong as it clearly was planned for a thinner handlebar but the garmin gets reasonably centered and i get the light on the correct position.
Hope you find usefull.
2E01DCBC-B4BA-4AF2-8348-843084C039DD.jpeg
7E920B4A-E838-4E38-B42F-BA477DC02D5B.jpeg
3340F111-0DB2-4E0B-A309-2038DF9F3042.jpeg
B7DA004B-F25A-4E5C-A8D8-51240DC8709B.jpeg
7325D4FF-F473-47F4-891D-1F5FE12B01DC.jpeg
 

EMTB Forums

Since 2018

The World's largest electric mountain bike community.

436K
Messages
20,814
Members
Join Our Community

Latest articles


Top