Kiox buttons jammed up. ?

Sean0711

Member
Nov 30, 2020
45
24
Surrey, uk
Hi all,

ive o lay had my rail about 3 weeks now and took it out for a ride today in some lovely weather! On getting back to the car completely soaked through and covered in mud. I went to turn off my kiox display and the buttons were solid. It looks like all the mud and grit from the ride have got in there and jammed them up. Has anyone else had this issue with the display or got a solution for it?

I’ve highlighted the areas in the photo of where all the grit is sitting.

thanks in advance.

682A3EFC-1215-48F9-BE74-83485224C4EC.jpeg
 

Sean0711

Member
Nov 30, 2020
45
24
Surrey, uk
Compressed air might help, perhaps?
I think I’ve managed to get most of it out with a very small detailing brush but will give it a blast tomorrow when I get into my workshop. The question is how do I stop it happening every time I go out for a wet winter ride, the kiox is mounted to the top tube and angled downwards so any crud that gets on there once it rains it washes down into the buttons. Some genius on here must have a solution for this? ?
 

Sean0711

Member
Nov 30, 2020
45
24
Surrey, uk
Mine did exactly the same yesterday. Buttons solid and unresponsive after a muddy/gritty ride.
Are they working again now you've cleaned it out?
Yep they are! Just seems like a real ball ache having to spend the best part of 45 mins with a tiny brush trying to get it all out. Glad I’m not the only one that’s having this issue!
 

yorkshire89

E*POWAH Master
Sep 30, 2020
468
657
North Yorkshire
Great. I'll have a go now - Was planning on going through warranty tomorrow...

Have you seen the screen covers you can get on Amazon? Tempted, I've already had a kiox display and handlebar controller fail possibly through water getting in.
 

Sean0711

Member
Nov 30, 2020
45
24
Surrey, uk
Great. I'll have a go now - Was planning on going through warranty tomorrow...

Have you seen the screen covers you can get on Amazon? Tempted, I've already had a kiox display and handlebar controller fail possibly through water getting in.
I have the reviews are bad! They say they fly off the first rough road you get too. I got a screen protector to stop scratches but think I’m gonna have to look for a type of cover. This is only the 4th time I have ridden my rail and the first time in the really rubbish weather. Was wet on other rides but nothing like today. Did they cover them for water getting in under the warranty??
 

yorkshire89

E*POWAH Master
Sep 30, 2020
468
657
North Yorkshire
I have the reviews are bad! They say they fly off the first rough road you get too. I got a screen protector to stop scratches but think I’m gonna have to look for a type of cover. This is only the 4th time I have ridden my rail and the first time in the really rubbish weather. Was wet on other rides but nothing like today. Did they cover them for water getting in under the warranty??

I've given it a good clean out with an old toothbrush for 30 mins and it's all working again, thanks! ?
I have the stem cap mount and there is a screw going through the magnet holding the kiox in place, not sure you have that with the top tube mount?
Water ingress was just what I thought probably happened, Bosch replaced the original and didn't say what was up with the first.

I'll get one of the silicone covers that also covers the buttons to hopefully stop this happening again...
 

Mteam

E*POWAH Elite
Aug 3, 2020
1,739
1,680
gone
I was going to put some electrical insulation tape over the top of just the button portion of the display in the hope that it kept most of the crud out, I've already taped up the USB port because I've had one kiox display fail most likely through water ingress in that port.

Its a poor design - bosch need to come up with something more suitable for proper off roading.
 

Sean0711

Member
Nov 30, 2020
45
24
Surrey, uk
I've given it a good clean out with an old toothbrush for 30 mins and it's all working again, thanks! ?
I have the stem cap mount and there is a screw going through the magnet holding the kiox in place, not sure you have that with the top tube mount?
Water ingress was just what I thought probably happened, Bosch replaced the original and didn't say what was up with the first.

I'll get one of the silicone covers that also covers the buttons to hopefully stop this happening again...
If you manage to find a case share a link please! All I can find is that plastic cover on Amazon for £20+ ?
 

yorkshire89

E*POWAH Master
Sep 30, 2020
468
657
North Yorkshire
It's arrived! Looks fairly well made, it's flexible and seems quite secure on the display.
Buttons are a bit harder to press but it's only the power button so not really an issue.
Worth £20? Well no but if it stops the kiox from playing up again it's got to be worth it

thumbnail_IMG_20201215_120254923.jpg
thumbnail_IMG_20201215_120244514.jpg
thumbnail_IMG_20201215_120533588.jpg
thumbnail_IMG_20201215_120555501.jpg
 

riddlemethis

Member
Jan 20, 2018
4
2
Australia
Same deal - power button stuck down after a really wet muddy ride. As said earlier -gave it a going over with an old tooth brush and then I dribbled some WD40 on to the button and left it for a couple of hours. Blew it out with compressed air and it came good.
 

EMTB Forums

Since 2018

The World's largest electric mountain bike community.

499K
Messages
24,245
Members
Join Our Community

Latest articles


Top