Bike bricked during firmware update?

monkeychild

New Member
Aug 13, 2018
23
9
Telford
Hey! I have ran the latest update on my Merida eOneTwenty with Steps E8000. The bike went to sleep whilst the firmware was updating and now the bike will not switch on
1f641.png
.
The battery is full (lights illuminate when you press the button with the battery off the bike), but will not do anything when actually on the bike.
 

mark.ai

E*POWAH Master
Patreon
Subscriber
Jul 10, 2018
811
575
Windermere
Ugh sounds annoying :eek:

Do you have the Shimano SM-PCE1 PC Interface (to connect to PC!) or did you do the update over Bluetooth with the phone app?

I have a feeling you will have to connect to it via PC to fix it ...
 

monkeychild

New Member
Aug 13, 2018
23
9
Telford
I did it via the app. It's a bit rubbish that Shimano allows this to happen. It's a 40 minute drive to the dealer.
 

monkeychild

New Member
Aug 13, 2018
23
9
Telford
Well it turns out either the battery or the motor is knackered!! I have contacted the shop in Europe I got it from as my local dealer wants paying labour to remove, package and replace the new parts.
The bike and display now turn on, but the motor doesn't engage and the speed isn't registered either.

error .jpg
 

mark.ai

E*POWAH Master
Patreon
Subscriber
Jul 10, 2018
811
575
Windermere
Oh damn that's even more annoying with the time to get it replaced!

I wonder if there was an undetected problem with the motor before the update (seems unlikely) or if performing the update and having it fail / go to sleep has bricked the motor (seems more likely).
 

monkeychild

New Member
Aug 13, 2018
23
9
Telford
Bloody infuriating is what it is!! I am today and tomorrow and wanted to ride :( Just waiting on the shop I bought it from to get back to me. As my local Merida dealer wants me to pay the labour charges.
 

monkeychild

New Member
Aug 13, 2018
23
9
Telford
I totally agree and I have messaged Shimano to tell them about it. I haven't heard anything back. The Firmware must write to the device on the fly as it's being transmitted, which is really bad coding. Especially as it shifts to standby mode after 10 minutes (which is what happened to mine). Not a happy bunny at the moment, just over a month of ownership and this happens :(
 

MattyB

E*POWAH Elite World Champion
Jul 11, 2018
1,264
1,275
Herts, UK
Well it turns out either the battery or the motor is knackered!! I have contacted the shop in Europe I got it from as my local dealer wants paying labour to remove, package and replace the new parts.
The bike and display now turn on, but the motor doesn't engage and the speed isn't registered either.

View attachment 6165
Bloody infuriating is what it is!! I am today and tomorrow and wanted to ride :( Just waiting on the shop I bought it from to get back to me. As my local Merida dealer wants me to pay the labour charges.
Sounds like they are trying to fob you off to me. If the bike was riding fine before the update and now it’s dead then the issue is not the battery or motor, it must be the software. I suspect they have just not seen this issue before and can’t be bothered/don’t have the expertise to troubleshoot it properly. Irrelevant of the cause, of the bike is in warranty and you used Shimanos own tool to flash the firmware there is no way you should be paying anything to fix it.

The Shimano system is definitely my favourite of the ones I’ve ridden to date, but stuff like this and the error messages that seem commonplace are making me nervous about choosing a bike with it, particularly as both my favourite Shimano powered bikes are direct sales only.
 
Last edited:

Kernow

E*POWAH Elite World Champion
Patreon
Founding Member
Jan 18, 2018
1,430
1,140
Cornwall uk
What is it with so many bike shops expecting you pay labour on warranty work
We wouldn’t accept this on our cars etc
I think they are playing a scam and getting paid twice because iam told by a dealer friend that shimano are excellent to deal with on warranty
 

Tamas

Well-known member
Founding Member
Jan 22, 2018
483
502
Hungary/Bosnia and Herzegovina
Sounds like they are trying to fob you off to me. If the bike was riding fine before the update and now it’s dead then the issue is not the battery or motor, it must be the software. I suspect they have just not seen this issue before and can’t be bothered/don’t have the expertise to troubleshoot it properly. Irrelevant of the cause, of the bike is in warranty and you used Shomanos own tool to flash the firmware there is no way you should be paying anything to fix it.

The Shimano system is definitely my favourite of the ones i’ve ridden to date, but stuff like this and the error messages that seem commonplace are making me nervous about choosing a bike with it, particularly as both my favourite Shimano powered bikes are direct sales only.

Shimano handles the warranty through their dealer network so it's irrelevant if you buy a direct sales bike. You can go to the Shimano ebike FB page send them a message and they get back with the necessary info in an hour. I have a Commencal Meta and the motor was replaced under warranty by my local Shimano dealer - for free of course. I don't understand how can they charge for warranty repair?
 

highpeakrider

E*POWAH Master
Subscriber
Aug 10, 2018
681
551
Peak District
My E8000 crashed during the update, then it said it was installing a default firmware.

That got stuck and would not load, one bricked bike.

I had an old iPhone 4s and tried that, bingo it loaded the default and updated the firmware.

Lesson learnt I’m not going to update it again.
 

monkeychild

New Member
Aug 13, 2018
23
9
Telford
My E8000 crashed during the update, then it said it was installing a default firmware.

That got stuck and would not load, one bricked bike.

I had an old iPhone 4s and tried that, bingo it loaded the default and updated the firmware.

Lesson learnt I’m not going to update it again.

Did you use an android device initially?

Apparently, there is an issue with BT on the older firmware.
 

MattyB

E*POWAH Elite World Champion
Jul 11, 2018
1,264
1,275
Herts, UK
It is pretty obvious that most of the manufacturers are clueless when it comes to software development - there seem to be issues with updates across most of the motor producers. It seems like being an early adopter of any new firmware is rather risky at this point; probably best to wait a few months for others to find the bugs before applying any new update.
 
Last edited:

taz

New Member
Nov 11, 2019
3
3
Tasmania, Australia
Digging up an old thread again but I have this exact same issue from a failed firmware update. I was using etube with the SM-PCE02 diagnostics tool to update a Merida/ Shimano e6000 series. I notice monkey child has not been around for some time, has anyone had this issue and resolved it? I am unable to error check as it requires the battery - etube detects the display and switch only and the battery wont turn on at all. I'd be forever grateful if anyone could instruct me on how to use etube to connect to the BT-E6010 battery and DUE-6001 motor as a single unit connection with the PCE02, I've tried googling it with no luck.

I've emailed Shimano regarding the issue and waiting for a reply, it's a 2nd hand bike that's out of warranty period but I can take it to the shop it came from as a last resort. I spoke to the LBD on the phone and he sounded clueless, he said he could hook it up and let Shimano remote trouble shoot it and that he had a customer before that had a similar issue and the motor never worked again; which as mentioned above sounds more like a lack of knowledge or care factor, maybe I'm a bit skeptical and I could be jumping the gun with the conclusion motor replacement is going to be his resolution but it would be better business for him to change the motor.

Update: fixed by connecting PCE02 direct to the motor and making a single unit connection to restore settings!
 
Last edited:

Gspot

Active member
Jul 28, 2019
126
22
NW
Update: fixed by connecting PCE02 direct to the motor and making a single unit connection to restore settings!

Could you explain a little more on this processs and result please.
 
Apr 25, 2019
45
25
Perth Western Australia
Anyone else having issues with Shimano servers? My bike seems to be bricked because the firmware update failed and now I get a message saying there may be a problem with Shimano's web server wait a little while and try again, I can't get past a screen about agreeing to the software terms and conditions, it won't bring up the agreement you are meant to read and won't let me click on the agree and update either....arrrgh. Oh this is followed by "an unexpected error has occurred" then I can only click OK, I'd really like to be able to click really not OK! Ok now past that screen only to get the below message which is what I got when it crapped itself the first time.
Screenshot_20200901-201255_E-TUBE.jpg
 
Last edited:

RickBullotta

E*POWAH Elite World Champion
Jun 5, 2019
1,541
1,299
USA
Anyone else having issues with Shimano servers? My bike seems to be bricked because the firmware update failed and now I get a message saying there may be a problem with Shimano's web server wait a little while and try again, I can't get past a screen about agreeing to the software terms and conditions, it won't bring up the agreement you are meant to read and won't let me click on the agree and update either....arrrgh. Oh this is followed by "an unexpected error has occurred" then I can only click OK, I'd really like to be able to click really not OK! Ok now past that screen only to get the below message which is what I got when it crapped itself the first time.

If this is the latest app (just pushed to mobile devices), it's a completely buggy piece of sh*t. Shimano needs to hire some competent software developers outside of Japan.
 

StuE

E*POWAH Master
Patreon
Jun 4, 2018
282
298
Leeds
I've deleted the fecking thing and will stick to using stunlocker, for a company the size of Shimano it's embarrassing that they should produce such a piece of crap
 

Top